Forum Index
The Boater's Guide to Information, Education & Scuttlebutt...
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Battery goes dead

 
Post new topic   Reply to topic     Forum Index -> Mercury / Mariner O/B
View previous topic :: View next topic  
Author Message
rick



Joined: 28 May 2009
Posts: 2

PostPosted: Thu May 28, 2009 9:31 am    Post subject: Battery goes dead Reply with quote

I have a 2005 Merc 90 ELPTO. After trolling for about an hour the battery is very low without even using the live wells. This is third battery. I have brand new one and same problem as the previous two new batteries?

at 3000rpm voltage is about 14.10
at 800 rpm idle in neutral, voltage is 13.06
at 650 rpm trolling , voltage gradually drops untill battery is dead

What should voltage be at 650rpm, do I have bad regulator?

I suspect the problem is right from the factory. what do you think

Rick
Back to top
View user's profile Send private message Send e-mail
MikeW
Senior Member


Joined: 01 May 2006
Posts: 680

PostPosted: Tue Jun 02, 2009 9:15 am    Post subject: Reply with quote

It sounds like it is charging correctly at higher rpm's. Call CDI Rapair and talk to the tech dept. The number is 256-772-3829 Cool
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic     Forum Index -> Mercury / Mariner O/B All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum